Sony Investigating Faulty PlayStation 4 Units

The issue first came to light when the PlayStation 4 given to game website IGN stopped outputting video through HDMI after updating the Netflix application for the system. After reaching out to readers, IGN received similar reports from Reddit.

A Reddit user named “aragon”, who won an early PS4 via a Taco Bell promotion, confirmed that their PlayStation 4 is suffering a similar problem.

Commenting in his AMA thread, he said: “When I turn on my console it just sits there pulsing blue. As far as I can tell it is supposed to turn white but it isn’t doing that. There is no signal on my tv either.”

aragon then contacted Sony support, but they were unable to help them before the console launches tomorrow. “I talked to at least 5 tech support people on the phone and 1 on-line. All of them but two outright refused to help me saying that the console is not yet released and they can’t help me. Two of the tech tried to help me boot it up into safe mode and that failed. At that point they both told me to call back Friday.”

Sony Worldwide Studios boss Shuhei Yoshida weighed in on the reports via twitter, saying “Be assured we are investigating reported PS4 issues. The number is very small compared to shipped, we believe they are isolated incidents.”

The PlayStation 4 launches in North American territories tomorrow and in European regions on 29th November, just in time for the holiday season. Fans are hoping that these early issues will be cleared up by the time the machine goes on sale to the public.


Posted

in

,

by

Comments

Leave a Reply